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MICROSOFT VISIO 2010
INTRODUCTION
The first thing that will confront most uses of Visio 2010 is the new “Fluent”
interface, and in particular the ribbon. For anyone migrating from an earlier
version of Visio without the benefit of having used another Office 2007 product,
the learning curve will seem steep indeed.
In Office 2010 the look and feel of the Fluent interface is clean and soothing on the
eye, with a pale grey color scheme to the ribbon and a slight drop shadow around
the page, and this look is consistent across the whole suite of programs. Whereas
some components of Office 2007 were given the Ribbon and others were not, all
the components of Office 2010 now use this new interface including Outlook,
Project and, of course, Visio.
DATA-CONNECTED VISIO DIAGRAMS
Instead of static pictures, you can create data-connected Visio Professional 2010
and Visio Premium 2010 diagrams that display data, are easy to refresh, and
dramatically increase your productivity. You can use the wide variety of diagram
templates and stencils in Visio to understand, act on, and share information about
organizational systems, resources, and processes throughout your enterprise.
You can integrate data to shapes from a variety of real-time data sources,
including Excel, Access, SQL, SharePoint lists, or any OLEDB or ODBC data
source, with just a few clicks in a Data Wizard.
FIND AND APPLY A TEMPLATE
Visio 2010 allows you to apply built-in templates, to apply your own custom
templates, and to search from a variety of templates available on Office.com.
Office.com provides a wide selection of popular Excel templates, including
process diagrams, network diagrams, and floor plans.
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To find and apply a template in Visio:
1.
On the File tab, click New.
2.
Under Choose a Template, do one of the following:

To use one of the built-in templates, under Template Categories, click the
category that you want, and then click the template that you want and click
Create.

To reuse a template that you have recently used, under Recently Used
Templates, click the template that you want and then click Create.

To use your own template that you previously created, under Other Ways
to Get Started, click New from existing, navigate to the file that you want
and click Create New.

To find a template on Office.com, under Other Ways to Get Started, click
Office.com templates, select the template that you want, and then click
Download to download the template from Office.com to your computer.
You can also search for templates on Office.com from within Visio. To search for
templates on Office.com, under Other Ways to Get Started, click Office.com
templates. In the Search Office.com for templates box, type one or more search
terms, and then click the arrow button to search.
To create a new diagram:
1.
Click the File tab. This opens up the Backstage view.
2.
You are in the Backstage view when you first open Visio. If you have just opened
Visio, proceed to the next step.
3.
Click New.
4.
Under Choose a Template, below Other Ways to Get Started, click Blank
drawing.
5.
Click Create.
When the diagram template opens, a blank diagramming page takes up most of
the space. Along the side is the Shapes window, which contains several stencils
full of shapes.
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Figure 1. Shapes Window displays stencils available based on the selected template.

Title bars at the top of the Shapes window identify the stencils; you might need to
scroll the title bar pane to see them all. When you click a stencil title bar, the
shapes appear in the pane below.
To open a diagram:
1.
Click the File tab, and then click Open.
2.
In the left pane of the Open dialog box, click the drive or folder that contains the
drawing.
3.
In the right pane of the Open dialog box, open the folder that contains the drawing
that you want.
4.
Click the drawing and then click Open.
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SAVE A DIAGRAM
You can save your diagram as a standard Visio file that you can share with other
people who have Visio. In addition, you can save your diagram in many different
formats that directly from the Save As dialog box.
To save a Visio diagram:
1. Click the File tab.
2. Click Save As, and then select a format in the Save as type list.
 Different formats are available for using or sharing your diagram.
o Standard image file include JPG, PNG, and BMP formats.
o Web page in HTM format. Visio will save image files and other resource files
in a subfolder of the location where you save the HTM file.
o PDF or XPS file.
o AutoCAD drawing in DWG or DXF format.
To add a shape:
1.
From the Shapes window, click and hold the shape that you want.
2.
Drag the shape onto the diagram page.
To add a shape to automatically connect to another shape on the drawing page,
do the following:
1.
2.
3.
4.
5.
6.
7.

Drag a first shape onto the drawing page.
Hold your pointer over the shape that is already on the page.
The shape with the AutoConnect arrows will appear.
Move the pointer to cover one of the arrows.
A mini toolbar that contains four shapes appears, and a preview shape might appear
on the page.
As you move the pointer over the shapes in the mini toolbar, previews of the shapes
appear. The shapes on the toolbar are the top four shapes from the Quick Shapes
area.
Click one of the shapes in the mini toolbar to add it to the page.
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To demonstrate this process, we created a WorkFlow Diagram and added the
Service Request shape. Notice that small blue AutoConnect arrows appear on the
four sides of the Service Request shape.

Figure 2. These are AutoConnect arrows that you can use to connect shapes.

To automatically connect two shapes when you drag the second shape onto
the page:
1.
Drag one shape onto the drawing page.
2.
Drag a second shape onto the drawing page and hold it so it covers the first shape,
but do not drop it yet. Notice that the AutoConnect arrows appear.
3.
Move the second shape down over the AutoConnect arrow that points in the
direction that you want, and drop it on the arrow.
To demonstrate this process, we dragged the Analyze shape to the bottom AutoConnect
arrow of the Service Request shape. When we released the mouse, the Analyze shape
was spaced a standard distance from the Service Request shape, and connected
automatically.

Figure 4. Drag the second shape to the
bottom AutoConnect arrow of the first
shape.

Figure 4. Release the mouse to observe
second shape now positioned a standard
distance from the first shape.
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To connect two shapes that are already on the page:
1.
Hold the pointer over one of the shapes that you want to connect.
2.
When the AutoConnect arrows appear, move the pointer over an arrow that is
pointing toward the shape that you want to connect.
3.
Click and hold the AutoConnect arrow, and then drag a connector from it to the
center of the other shape.
4.
When the arrow is over the center of the other shape, a red border appears around
the shape.
5.
Drop the connector to attach it, or "glue" it, to the shape.
ADDING TEXT TO SHAPES OR TO THE PAGE
To add text to a shape:
1.
Select the shape that you want to add text to.
2.
Type the text that you want.
3.
When you start typing, Visio switches the selected shape to text editing mode. To
add another line of text, press ENTER.
4.
Click an empty area of the page, or press ESC when you are finished.
5.
Select the shape again. A small yellow control handle appears in the text area.
6.
Drag the yellow control handle to move the text.
To add text to the page:
1.
On the Home tab, in the Tools group, click the Text tool.
2.
Click an empty area of the page. A text box appears.
3.
Type the text that you want.
4.
On the Home tab, in the Tools group, click Pointer Tool to stop using the Text
tool.
The text box now has the characteristics of other shapes. You can select it and type
to change the text, you can drag it to another part of the page, and you can format
the text by using the Font and Paragraph groups on the Home tab.
In addition, when you hold the pointer over the text, AutoConnect arrows appear
so you can connect the text to other shapes.

Page 6
\\OFFICE-XP\XP_My Documents\1_Presentation Choices\Clients\Starlight Education\Outlines and Docs_posted\Visio 2010 Cheat Sheet.docx
Last printed 10/17/2013

Microsoft Visio 2010 – Cheat Sheet
Training Division
Special Edition

To enter data into a data property or field that a shape already has, do the
following:
To add data to a shape:
1.
Select a shape on the drawing page.
2.
Right-click the shape and click Shape Data.
3.
In the Shape Data window, in the property row that you want, enter the data that
you want.
To define a new data property or field for a shape:
1.
Select a shape on the drawing page.
2.
Right-click the shape and click Define Shape Data.
3.
In the Define Shape Data dialog box, click New
4.
In the Label box, delete the default text and type a name for the property.
5.
In the Type list, select the type of data that you want to enter into that property.
6.
TIP
If you want the property to accept text (like a person’s name) as the type of
data, select String.
7.
In the Value box, type the value of the data that you want.
8.
Click OK.
9.
Right-click the shape again, point to Data, and this time click Shape Data.
The Shape Data window opens and displays all the data defined for the shape. If
all of the shapes have specific information, you can leave the Shape Data window
open and click the shapes you are interested in to see the data they contain.
CONNECT DATA SOURCES TO SHAPES
Adding shape data manually can add a lot of value to your diagram, but if your
data is in a database or an Excel workbook, you can pull that data into your
diagram automatically and connect the rows of data with specific shapes.
Use the Data Selector wizard to import your data into the External Data window.
The data that appears in the External Data window is a snapshot of your source
data at the time of import. You can update the data in your drawing to match the
changes in your source data by clicking Refresh All on the Data tab.

Page 7
\\OFFICE-XP\XP_My Documents\1_Presentation Choices\Clients\Starlight Education\Outlines and Docs_posted\Visio 2010 Cheat Sheet.docx
Last printed 10/17/2013

Microsoft Visio 2010 – Cheat Sheet
Training Division
Special Edition

To connect data sources to shapes:
1.
On the Data tab, in the External Data group, click Link Data to Shapes.
2.
On the first page of the Data Selector wizard, choose which of the following types of
data sources have the data you're using:

Microsoft Office Excel workbook

Microsoft Office Access database

Microsoft Windows SharePoint Services list

Microsoft SQL Server database

Other OLEDB or ODBC data source
3.
Complete the remainder of the wizard.

After you click Finish on the last page of the Data Connection wizard, the
External Data window appears with your imported data shown in a grid. Drag a
row of data onto a shape to add automatically the data to the Shape Data for that
shape. Alternatively, in the Shapes window, select a shape that you want to hold
the data, and then drag a row of data and drop it on an empty area of the page.
You have now added the selected shape to the page and connected to the data.
FORMATTING YOUR DIAGRAM
To apply a background to your drawing, do the following:
1.
Click the Design tab.
2.
In the Backgrounds group, click Backgrounds.
3.
Click the background that you want.
You will see a new background page added to the diagram along with the new
background page tab along the bottom of the diagramming area.
To apply a border or title to your drawing:
1.
On the Design tab, click Borders & Titles.
2.
Click the title that you want.
Visio adds the title and border to the background page (named VBackground-1 by
default).
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3.
4.

To change the title and other text, you must make the changes on the background
page; you cannot change the title on any other pages.
At the bottom of the diagramming area, click the VBackground-1 tab.

Figure 5. Tabs at the bottom of the Diagram page.

5.
6.
7.

Click the title text. Notice clicking the title text selects the entire border. Once you
start typing, the default title text changes.
Enter the title that you want.
To edit other text in the border, first select the entire border, and then click the text
you want to change and start typing.

To apply a unified color scheme and other formatting effects:
1.
On the Design tab, in the Themes group, hold your pointer over the various
themes. A preview of the theme shows up on the page.
2.
To see other available themes, click More .
3.
Click the theme you want to apply to the diagram.
To print your diagram:
1.
Click the File tab and then click Print.
2.
To print the diagram, click Print.
3.
In the Print dialog box, do the following:
4.
In the Name box, select the printer that you want (if it not already selected).
5.
Under Page range, specify the pages in the drawing that you want to print.
6.
Under Copies, specify the number of copies that you want to print.
7.
Click OK when you are ready to print.
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