Tips and Tricks for Microsoft Excel 2013
# Table of Contents

Worksheet Basics.......................................................................................................................... 1
One Workbook, One Window .......................................................................................................... 1
Move to the End of a Row or Column of Data ............................................................................ 1
Select Cells Without Scrolling ...................................................................................................... 2
Select Non-Adjacent Ranges ......................................................................................................... 2
Rename a Sheet ............................................................................................................................... 2
Shortcuts for Navigating Different Sheets .................................................................................. 2
Type Data Efficiently in Lists ...................................................................................................... 3
   Flash Fill .................................................................................................................................. 3
   AutoComplete ......................................................................................................................... 3
   Pick from List ........................................................................................................................... 4
Extract Text from a Cell ................................................................................................................ 4
Break Text in a Single Column into Multiple Columns ............................................................... 4
Wrap Text with Precision ............................................................................................................ 4
AutoFill Tricks .............................................................................................................................. 5
Custom Lists ............................................................................................................................... 6
Quick Analysis .............................................................................................................................. 6
AutoSum Tricks ............................................................................................................................. 7
View Calculations in the Status Bar ............................................................................................. 7
A Better Way to Crunch a Formula ............................................................................................... 7
Show Formulas ............................................................................................................................ 7
Keep the Result, Lose the Formula .............................................................................................. 8
Move or Copy by Dragging ........................................................................................................... 8
Repeat Last Action ...................................................................................................................... 9
Repeat Previous Value ................................................................................................................ 9
Keyboard Shortcuts for Current Date and Time ......................................................................... 9
Create Absolute References Using One Key .............................................................................. 9
Charting the Easy Way ................................................................................................................ 10
   Create A Chart Using Quick Analysis Tool ......................................................................... 10
   Charts Recommendations ..................................................................................................... 10
   Create a Chart with a Single Key ......................................................................................... 11
Add Cell Comments .................................................................................................................... 12
Sort a List the Easy Way ............................................................................................................. 12
Filter a List .................................................................................................................................. 12
Use Advanced Filter ................................................................................................................... 13
Add Subtotals to a List ............................................................................................................... 13
Create Nested Functions Using the Mouse ................................................................................. 14
The Backstage View ................................................................................................................... 14
Worksheet Basics
When you open Excel 2013, you will see templates for budgets, calendars, forms, and reports, and more.

The first thing you will see when you open Excel is a brand new look. It is cleaner, and designed to help you get professional-looking results quickly. You will find many new features, some of which described in this document.

One Workbook, One Window

In Excel 2013 each workbook has in its own window, making it easier to work on two workbooks at once. It also makes life easier when you are working on two monitors.

Move to the End of a Row or Column of Data
Each worksheet has 16,384 columns (A – XFD) and 1,048,576 rows (1 – 1048576).

To move to the end of a row or column of data, hold down the [Ctrl] key and press the [Arrow] key representing the direction you want to move.
Select Cells Without Scrolling
1. Click in the first cell.
2. Hold down the [Shift] key.
3. Navigate to the last cell using the keyboard. For example, while holding down the [Shift] key, press [Ctrl]+[Down Arrow] to navigate to and select a column of data or press [Ctrl]+[Down Arrow] to navigate to and select a row of data.

Tip: Combine both of these techniques to select all rows and columns in a list.

Tip: You can also navigate to a particular cell by clicking in the Name box, typing the name of the cell to which you wish to move and pressing [Enter].

Select Non-Adjacent Ranges
1. Select the first range using the mouse or the keyboard.
2. Hold down the [Ctrl] key and select an additional range(s) using the mouse.

Rename a Sheet
To rename a sheet:
1. Double-click the sheet tab of the sheet you wish to rename
2. Type the new name
3. Press [Enter]

NOTE: You can also right-click the tab and click Rename

Shortcuts for Navigating Different Sheets
- To navigate to the next sheet, press [Ctrl]+[Page Down]
- To navigate to the previous sheet, press [Ctrl]+[Page Up]
- To navigate to a specific sheet, right-click the Sheet Tab Scrolling buttons and click the name of that sheet
Type Data Efficiently in Lists

Flash Fill
Fill out an entire column of data in a flash

Flash Fill is like a data assistant that finishes your work for you. As soon as it detects what you want to do, Flash Fill enters the rest of your data in one fell swoop, following the pattern it recognizes in your data. To see when this feature comes in handy,

Your data does not have to be names, of course. Flash Fill works with any data you need to split into more than one column, or you can simply use it to fill out data based on an example. Flash Fill typically starts working when it recognizes a pattern in your data. However, Flash Fill may not always start filling out your data. It works best when your data has some consistency. For example, all names have middle initials or all addresses use the same type of postal codes. If your data has many inconsistencies, you can always use Text to Columns to split text into different cells, or use functions to split text.

AutoComplete
When entering data into a list, Excel looks for an existing value in that column that matches the character(s) you have entered so far. For example, if you enter a “d” and the only value you have entered into that column that begins with a “d” is “dinosaur”, Excel will insert the word dinosaur into the current cell. If, on the other hand, you have several existing entries in that column that begin with “d” (i.e. dinosaur, duck and dog) Excel will insert the matching word when you have typed enough characters to differentiate between the entries. In this case, you would have to type “di” before Excel will find the match.

Once Excel has inserted the matching entry, you can:

- press [Tab] to accept the inserted entry and move to the next column
  OR
- press [Enter] to accept the inserted entry and move to the next row
  OR
- if the matching entry suggested by Excel is incorrect, simply continue typing.
**Pick from List**

To repeat an entry that has already been entered in a column of a list, right-click the cell in which you wish to repeat the entry and select **Pick From Drop-down List**, then click the entry you wish to repeat.

**Extract Text from a Cell**

You can extract the leftmost or rightmost text from another cell with the following functions:

\[
\text{LEFT}(\text{Text}, \text{Num\_chars}) = \text{RIGHT}(\text{Text}, \text{Num\_chars})
\]

where `Text` is the cell containing the text you wish to extract and `Num\_chars` is the optional number of characters to be extracted. If left blank, `Num\_chars` defaults to 1.

You can extract characters from the middle of a label in another cell using the following formula:

\[
\text{MID}(\text{Text}, \text{Start\_num}, \text{Num\_chars})
\]

where `Text` is the cell containing the text you wish to extract, `Start\_num` is the position of the first character you wish to extract and `Num\_chars` is the number of characters to be extracted.

**Break Text in a Single Column into Multiple Columns**

1) Select the cell(s) containing the text you wish to break into several columns.
2) Click the **Text to Columns** button on the **Data** tab.
3) Choose **Delimited** and click **Next**.
4) In the “Delimiters” section, choose the character that indicates where the text is to be broken (i.e. Space) or click Other and type the appropriate character.
5) Click **Finish**.

NOTE: The cell(s) to the right of the selected text should be blank so that you don’t overwrite existing data.

**Wrap Text with Precision**

To wrap text in a cell at a specific location, enter the label in the cell, pressing `[Alt]+[Enter]` at the point you wish the text to wrap to the next line.
AutoFill Tricks

The AutoFill button can be used to quickly populate a series of cells with labels such as month names or the days of the week. To populate a series of cells with these labels:

1) Type the first label (i.e. January or Monday) into the first cell of the series
2) Position the mouse pointer on the AutoFill button until the mouse pointer becomes a + as shown below.

3) Hold down the left mouse button and drag down to continue the labels in that column or drag to the right to continue the labels in that row.

**TIP:** AutoFill can also be used to copy a formula to additional cells in the same column.

**TIP:** The AutoFill feature can also be used to populate a series of cells with a label that begins or ends with a sequential value. For example, if you type “Week 1” into the first cell and then grab the AutoFill handle and drag to the next 5 cells to the right, you will see the following results.
TIP: You can use the AutoFill feature to populate a specific sequence of numbers. If you type “100” in the first cell and “200” in the cell just below or to the right and then select BOTH cells, you can AutoFill a series of numbers where each number is 100 more than the one before it, as shown below.

TIP: Double-clicking the AutoFill button automatically fills that column as far as there is data in the adjacent column to the left or right.

Custom Lists
1) Click the File tab and select Options.
2) Click the Advanced category.
3) Scroll down and click the Edit Custom Lists button.
4) Click in the “List entries” box and type the list items, pressing [Enter] after each item and click the Add button

OR
Click in the “Import list from cells” box, select the cells in a worksheet that contain the items for the list and click the Import button.

5) Click OK twice.

Quick Analysis
Instant data analysis with Quick Analysis Tool

The new Quick Analysis tool lets you convert your data into a chart or table in two steps or less. Preview your data with conditional formatting, Sparklines, or charts, and make your choice stick in just one click.
AutoSum Tricks
To sum a column of numbers including blanks:
1) Highlight the numbers including empty cells.
2) On the Home tab of the ribbon, click the Σ AutoSum button
   OR
On the Formulas tab of the ribbon, click the Σ button
   OR
Press [Alt]+[=].

To sum all columns or rows at once:
3) Select the blank cells into which you wish to place the totals, either the row below the numbers or the column to the right of the numbers.
4) On the Home tab of the ribbon, click the Σ AutoSum button
   OR
On the Formulas tab of the ribbon, click the Σ button
   OR
Press [Alt]+[=].

View Calculations in the Status Bar
1) Highlight the numbers whose result you wish to see displayed in the Status Bar.
2) If the Status Bar does not display the correct calculation, right-click the Status Bar and select the calculations you would like to see.

A Better Way to Crunch a Formula
When entering a formula, press [Ctrl]+[Enter] to enter the formula into the cell and leave the cell pointer in that cell. That way, you can still see the formula in the Formula Bar while also viewing the result of the formula.

In addition, if your formula contains more than 1 operator (i.e. =B3+B4+B5/3) or contains nested functions (i.e. =LEFT(A5,FIND("-",A5)), you may want to verify that the formula is calculating as intended. Select the cell containing the formula and click the Evaluate Formula button on the Formulas tab. The first part of the formula that will be calculated is underlined. Click the Evaluate button as many times as necessary to see the order in which each of the calculations in the formula will be made.

Show Formulas
To see the formulas entered into the cells of a worksheet rather than the RESULTS of the formulas, press [Ctrl]+[-] or click the Show Formulas button on the Formulas tab. This is a great way to check all of your formulas for accuracy. When you wish to turn off the formulas and see the results again, simply press [Ctrl]+[-] again or click the Show Formulas button on the Formulas tab.
Keep the Result, Lose the Formula
1) Select the cell(s) containing the formula whose result you would like to copy.
2) Copy the cells ([Ctrl]+[C] or right-click and select Copy or click the Copy button on the Home tab).
3) Click in the new location for the data (the new location may be the same as the previous location).
4) On the Home tab of the Ribbon, click the lower part of the Paste button and click one of the Paste Values buttons listed below.

Move or Copy by Dragging
1) Select the cell or range to be moved or copied.
2) Point to the edge of the selected cell(s) until the mouse pointer changes to a Northwest-pointing arrow, as shown below.
3) Do one of the following:

- Drag the cell(s) to move the cell(s) to a new location
- To copy the cell(s) to a new location
- To move and insert cell(s) between existing cells without replacing cells in the move location
- To copy and insert cell(s) between existing cells without replacing cells in the move location

Select the border of the range and drag to a new location.

- [Ctrl] drag the cell(s)
  (Notice the curser changes to a white arrow with a + attached.)
- [Shift] drag the cells
- [Shift]+[Ctrl] drag the cell(s)

Repeat Last Action
Press the [F4] key to repeat the last action.

Repeat Previous Value
To repeat the value in the cell directly above the current cell, press [Ctrl]+['] (apostrophe).

Tip: Selecting the range into which you wish to add data BEFORE typing restricts the movement of the cell pointer to the selected cells. For example, typing an entry and then pressing [Enter] will move you to the next cell down in the selected range. If you are at the bottom of the selected range, you will move to the top of the next column in the range. Typing an entry and pressing [Tab] will move you to the next cell to the right in the selected range. If you are in the far right cell of the range, the cell pointer will move to the beginning of the next selected row.

Keyboard Shortcuts for Current Date and Time
- To enter the current date in a cell, press [Ctrl]+[:]
- To enter the current time in a cell, press [Ctrl]+[Shift]+[:]

Create Absolute References Using One Key
To create an absolute reference while creating or editing a formula, press the [F4] key when the cursor is touching the cell reference you wish to be absolute.
Charting the Easy Way

Create A Chart Using Quick Analysis Tool

1) Select the data for your chart.

2) Click the Quick Analysis button that appears to the bottom right of your selected data (or press CRTL + Q).

3) In the Quick Analysis gallery, select the Charts tab and hover your mouse over each type to preview your data in a chart on the worksheet.

Charts Recommendations

Excel recommends the most suitable charts for your data. Get a quick peek to see how your data looks in the different charts, and then simply pick the one that shows the insights you want to present.

1) From the Insert Tab, select Recommended Charts
2) On the **Recommended Charts** tab, scroll through the list of charts that Excel recommends for your data, and click any chart to see how your data will look.

![Recommended Charts Tab](image)

**Tip**  If you do not see a chart you like, click **All Charts** to see all available chart types.

3. When you find the chart you like, click it > **OK**.

4. Use the **Chart Elements**, **Chart Styles**, and **Chart Filters** buttons next to the upper-right corner of the chart to add chart elements like axis titles or data labels, customize the look of your chart, or change the data shown in the chart.

![Chart Elements and Filters](image)

**Create a Chart with a Single Key**

To create a chart quickly, click in or select the range of data for the chart, then press the **[F11]** function key.

A new chart will appear on a separate worksheet.
Add Cell Comments
You can add non-printing comments to a worksheet by:

♦ Right-clicking the cell you wish to comment on and selecting Insert Comment.

OR

♦ Selecting the cell you wish to comment on and clicking the New Comment button on the Review tab.

NOTE: To view a comment, hover over a cell with a red triangle in the upper right corner. To edit or delete a comment, right-click the cell and click Edit Comment or Delete Comment.

Sort a List the Easy Way
If your list contains only one row of column headings, does not contain any blank rows or columns AND is entirely surrounded by blank rows and columns, you can quickly sort your list using the following steps:

♦ Right-click anywhere in the column on which you wish to base your sort.

♦ Click Sort > Sort A to Z

OR

♦ Click Sort > Sort Z to A

NOTE: You can also sort by text color or cell color!

Filter a List
If your list contains only one row of column headings, does not contain any blank rows or columns AND is entirely surrounded by blank rows and columns, you can quickly filter your list using the following steps:

1. Click on any cell in the list to be filtered.
2. Click the Filter button on the Data tab.
3. Click the arrow to the right of the column heading for the column you wish to filter.
4. Deselect the items you wish to hide.

NOTE: To redisplay all items in a list, click the arrow to the right of the column heading of the filtered column and click (Select All).
Use Advanced Filter

The Advanced Filter feature is useful when you need to create a list of unique entries in a particular column. To use the Advanced Filter feature to create a list of unique entries:

1) Copy the heading for the column to be filtered to a blank area of the worksheet.
   a. Select the column to be filtered.
   b. Click the Advanced button on the Data tab.

2) Select Copy to another location.

3) In the “Criteria range” box, select the cell to which you copied the heading in step 1 and the blank cell below that heading.

4) In the "Copy to" box, type the name of the cell where you want the unique list to start.

5) Click the Unique records only check box to enable that feature.

6) Click OK.

Add Subtotals to a List

If your list contains only one row of column headings, does not contain any blank rows or columns AND is entirely surrounded by blank rows and columns, you can quickly add subtotals your list using the following steps:

1) Click on any cell in the column for which you wish to generate subtotals.

2) On the Data tab, click the or to sort the list by that column.

3) On the Data tab, click the Subtotal button.

4) Under “At each change in” select the column on which you sorted in step 2.

5) Under “Use function”, select the calculation you wish to use.

6) Under “Add subtotal to” select the column(s) to be calculated.

7) Click OK.

NOTE: To remove the subtotals, click anywhere in the list, click the Subtotal button on the Data tab and click Remove All.
Create Nested Functions Using the Mouse

1) Enter the outer function into a cell.

2) At the point in the formula where you wish to nest a second function, click the arrow to the right of the Functions box and select the function you wish to nest, or click More Functions to nest a function not listed.

The Backstage View

The Backstage View takes on a new look and the Ribbon Tabs are no longer visible. To return to the Ribbon Tabs, click the arrow in the top left corner of the Backstage View or press the ESC key.

In earlier versions of Excel you can exit Excel and close all open workbooks at once. To reduce confusion about the different close and exit commands in Office Backstage view (File tab), Exit was removed in Excel 2013.

File > Close or the Close button (in the upper-right corner of the application window) only closes workbooks one at a time. To exit Excel the way you did before, add Exit to the Quick Access toolbar (File > Options > Quick Access Toolbar), or right-click the Excel icon on the Windows Taskbar to pick Close all windows.